For Developers

The Archivists’ Toolkit application is available as open source, free software under the Educational Community License, v. 1.0

Contributing Code:
Read the guidelines if you are considering contributing code to the AT. Consider developing a plugin before you decide to contribute or modify the core code.

Javadocs:
AT 1.1.8 Javadocs
AT 1.5.9 Javadocs
AT 2.0.0 Javadocs

Read the license under which the AT is distributed before contributing code or distributing derivations of the code.

NOTES ON COMPILING ARCHIVISTS TOOLKIT 2.0 FROM SOURCE CODE:

This assumes you already have basic knowledge of how to compile and run Java programs using your IDE of choice. The current source needs to be compiled with JDK 1.5, or the latest JDK 1.6. Also you need to first install the ArchivistsToolkit program, since the source needs to be unpacked in the folder where it was installed. All compile time dependencies are found in the "lib" folder. See below for more details.

1. Download the latest source code
2. Unzip the source code in the ArchivistsToolkit installation folder. There should now be a "src" folder which contains the source code, along with the conf, lib, logs, and reports folder. Those folders contain files needed to run the compiled version of the AT, and therefore should be set as the working directory in your IDE.
3. Import the source code into your IDE.
4. In your IDE, place all the *.jar files, except "ArchivistsToolkit.jar", found in the "lib" folder in the Classpath.
5. You should now be able to compile and run the AT from source code.

If you intend to modify user interface code, then you will need to use JFormdesigner to open the *.jfd files. Consult the JFormdesigner documentation on how to install and use it.

AttachmentSize
ArchivistsToolkit-with-src1_1_8.jar3.55 MB
ArchivistsToolkit-with-src1_5_9.jar4 MB
ArchivistsToolkit-src2_0_0u15.zip2.57 MB
ATPlugin_DevGuide.pdf301.23 KB